Skip to content

Private DNS configuration not working on linux #1302

Description

@technics3

I am using Netclient 1.5.1 on a Debian 13 host with systemd-resolved and wireguard-tools installed.

I can connect to my Netmaker server fine and talk to every hosts on the VPN, but the DNS configuration on this host is not working.

avril 29 13:51:09 lys-lymic netclient[2706]: [netclient] 2026-04-29 13:51:09 Starting firewall...
avril 29 13:51:09 lys-lymic netclient[2706]: [netclient] 2026-04-29 13:51:09 using iptables to manage firewall rules...
avril 29 13:51:09 lys-lymic netclient[2706]: [netclient] 2026-04-29 13:51:09 flushing netmaker rules...
avril 29 13:51:09 lys-lymic netclient[2706]: [netclient] 2026-04-29 13:51:09 adding forwarding rule
avril 29 13:51:10 lys-lymic netclient[2706]: [netclient] 2026-04-29 13:51:10 creating systemd stub manager
avril 29 13:51:10 lys-lymic netclient[2706]: {"time":"2026-04-29T13:51:10.006147169+02:00","level":"ERROR","source":"systemd_linux.go 123}","msg":"error resetting interface (netmaker) dns nameserver settings: exit status 1: Failed to resolve interface \"netmaker\": Aucun périphérique de ce type"}
avril 29 13:51:10 lys-lymic netclient[2706]: [netclient] 2026-04-29 13:51:10 error initializing dns manager: failed to cleanup config for interface (netmaker): exit status 1
avril 29 13:51:10 lys-lymic netclient[2706]: completed pull for server <REDACTED>
avril 29 13:51:10 lys-lymic netclient[2706]: [netclient] 2026-04-29 13:51:10 adding addresses to netmaker interface
avril 29 13:51:10 lys-lymic netclient[2706]: [netclient] 2026-04-29 13:51:10 initialized endpoint detection on port 51821
avril 29 13:51:10 lys-lymic netclient[2706]: [netclient] 2026-04-29 13:51:10 initialized endpoint detection on port 51821
avril 29 13:51:11 lys-lymic netclient[2706]: [netclient] 2026-04-29 13:51:11 adding addresses to netmaker interface
$ sudo resolvectl status
Global
         Protocols: +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
  resolv.conf mode: stub

Link 2 (ens18)
    Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
         Protocols: +DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server: 10.10.10.11
       DNS Servers: 10.10.10.11 10.10.10.10
        DNS Domain: <REDACTED>
     Default Route: yes

Link 7 (netmaker)
    Current Scopes: none
         Protocols: -DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
     Default Route: no

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions